PDA

View Full Version : Problem with autochair Olympian hoist.



touchstone
10-15-2016, 08:25 AM
To enable me to load and unload my wife's mobility scooter into our car I purchased a used Olympian hoist. The hoist was sourced and fitted by and on the recommendation of my local Mobility organisation. It worked fine and then! When I came to unload the scooter, having placed the scooter on the road (and removed the slings so that my wife could use the scooter), I found that the lifting arm could not be raised and remained sticking out of the back of the car.
I checked the power supply to the hoist control and it was OK.
The motor that controlled the swivel in/out movement was working but not the lift or lower. Operating the lift control I could hear a clicking from the motor but it refused to budge.
I assume there must be some form of limiting device that stops the hoist from lifting to high and damaging the roof of the car and lowering to low but where is it located?
In my youth I specialized in electro mechanical equipment and although I have looked I can't find any information on fault finding or repair of this unit. Can any one provide me with such information?
Thanks.

dlfteam
10-18-2016, 08:27 AM
Hi touchstone

The supplier, Autochair, is also the manufacturer so I would contact them for troubleshooting problems; link below;

http://www.dlf-data.org.uk/report_items.php?reportid=5805d749c3f5c&view

Dlfteam

Lighttouch
10-18-2016, 10:00 AM
Should you need any help or advice on the repair of an existing product, we’d be happy to help – just ring the Autochair service team on 0808 256 9368.